nixconfig/systems/sandbox/hardware.nix
soraefir 05bf386e51
All checks were successful
Nix Build / build-nixos (push) Successful in 5m30s
Fix
2024-04-14 21:25:20 +02:00

15 lines
467 B
Nix

{ config, lib, pkgs, modulesPath, ... }: {
imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
boot.kernelPackages = pkgs.linuxPackages_latest;
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
boot.loader.grub.device = "/dev/sda";
boot.initrd.availableKernelModules =
[ "ata_piix" "uhci_hcd" "xen_blkfront" "vmw_pvscsi" ];
boot.initrd.kernelModules = [ "nvme" ];
fileSystems."/" = {
device = "/dev/sda3";
fsType = "btrfs";
};
}