soraefir c636f15689
Some checks failed
Nix Build / build-nixos (push) Failing after 20s
sops&server
2024-05-16 00:13:16 +02:00

23 lines
685 B
Nix
Executable File

{ pkgs, ... }:
let
nixflake_dir = "$HOME/files/nixconfig";
nixflake_url = "git+https://git.helcel.net/sora/nixconfig";
in {
programs.zsh = {
enable = true;
shellAliases = {
"sudo" = "sudo ";
"devsh" =
"nix develop --profile /tmp/devsh-env ${nixflake_url}#devsh -c zsh";
"nixb" = "(sudo nixos-rebuild switch --flake ${nixflake_url})";
"nixgc" = "sudo nix-collect-garbage -d && nix-collect-garbage -d";
"ssh" = "TERM=xterm-256color ${pkgs.openssh}/bin/ssh";
"top" = "btop";
};
initExtra = ''
sopsu() {nix-shell -p sops --run "sops updatekeys $1";}
sopsn() {nix-shell -p sops --run "sops $1";}
'';
};
}